[TLUG] Re: [TLUG] dwa polpaki, again

##makaron## tlug at linux.gda.pl
Tue, 22 Mar 2005 10:47:15 +0100


Witam,
Polecam to FAQ, jest tam opisana sytuacja dwóch łącz do providera.
http://lukasz.bromirski.net/projekty/cisco_faq_pl/cisco_faq_pl.html
---- Wiadomość Oryginalna ----
Od: Rafał Woźniak <tlug1@rafal.wozniak.name>
Do: tlug@linux.gda.pl
Data: Tue, 22 Mar 2005 10:37:26 +0100
Temat: Re: [TLUG] dwa polpaki, again

> Dnia wtorek, 22 marca 2005 09:29, Tomasz Witek napisał:
> &gt; Jest sobie taki router:
> &gt;
> &gt; Cisco 2501 Router - 2x serial V.35, 1x Ethernet 10Base-T
> &gt; 16 MB DRAM, 8MB Flash, IOS IP
> &gt;
> &gt; ma 2 seriale wiec moge go podlaczyc do dwoch modemow.
> &gt;
> &gt; Tylko nei mam pojecia co dalej.
> &gt;
> &gt; No tak moge skonfigurowac oba interfejsy (o ile bede umial)
> &gt;
> &gt; jeden ethernet ? wiec co on tam robi ?
> &gt;
> &gt; Load balacncing ? sam ? po sesji ?
> &gt;
> &gt; co spakietami udp / raz wysyla jednym raz drugim ?
> &gt;
> &gt; kupa pytan bez odpowiedzi.
> &gt;
> &gt; Jak to bedzie dzialac ?
> &gt;
> &gt; TiweK
> 
> ja to robię tak (w przypadku dwóch polpaków to pikuś ;):
> założenia:
> - nie masz loadbalancingu wykupionego od tepsy
> - do polpak I adresy przypisane (potrzebne do przykładu, wstaw swoje)=
: 
> 10.0.0.0/28
> - do drugiego polpaku: 10.1.0.0/28
> - połączenia WANowskie (tez przykład): 192.168.0.0/30 (polpak I)
> - WAN polpak II: 192.168.1.0/30
> 
> na routerze dopisz:
> 
> ---------------
> interface FastEthernet0
>  ip address 192.168.0.1 255.255.255.240
>  ip address 192.168.1.1 255.255.255.240 secondary
>  ip policy route-map lacze
> 
> ip route 0.0.0.0 0.0.0.0 192.168.0.1
> access-list 110 permit ip 10.1.0.0 0.0.0.15 any
> 
> route-map lacze permit 10
>  match ip address 110
>  set ip default next-hop 192.168.1.1
> ----------------
> 
> na serwerze, który robi za NAT (w moim przypadku Debian, więc poniż=
ej wycinek 
> z pliku /ec/network/interfaces):
> 
> # Polpak I
> auto eth0
> iface eth0 inet static
>         address 192.168.0.2
>         netmask 255.255.255.240
>         network 192.168.0.0
>         broadcast 192.168.0.15
>         gateway 192.168.0.1
> 
> # Polpak II
> auto eth0:1
> iface eth0:1 inet static
>         address 192.168.1.2
>         netmask 255.255.255.240
>         network 192.168.1.0
>         broadcast 192.168.1.15
> 
>         up route add -net 128.0.0.0/1 gw 192.168.1.1 eth0:1
> 
> i w taki sposób mam mniej więcej po równo obciążone polpaki.
> Ideę tą stosuję z powodzeniem do nawet 6 polpaków.
> Do plusów takiego rozwiązania należy to, iż można sobie wybra=
ć przez który 
> polpak chcemy się logować na serwer gdy jesteśmy poza naszym LANe=
m. Gdy 
> padnie jeden polpak to można się zalogować poprzez drugie łąc=
ze.
> 
> 
>